$re = '/(?<=\d)abc/';
$str = '123abc
acbabc
!@#abc';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);