// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"\<p class\=\"ekk-normal-text\"\>"#).unwrap();
let string = "<div class=\"field-item even\" property=\"content:encoded\"><p class=\"ekk-summary-text\">Les sociétés coopératives d’habitation <span class=\"CHA-SUITE\">existent toujours. Dans le Jura, l’une d’elles vient d’inaugurer un nouvel immeuble.</span></p>
<p class=\"ekk-summary-text\">L’habitat coopératif <span class=\"CHA-SUITE\">rappelle l’époque où il s’agissait d’offrir des logements sociaux aux ouvriers mal payés. Aujourd’hui, on n’en est plus là.</span></p>
<p class=\"ekk-summary-text\">La philosophie <span class=\"CHA-SUITE\">demeure: offrir un logement de qualité à prix abordable à des locataires qui ont leur mot à dire. Et pour cela, il y a toujours un avenir. Enquête.</span></p>
<p class=\"ekk-normal-text\">Aujourd’hui, les coopératives d’habitation ne représentent que 2 ou 3% des logements dans le Jura, contre 5 à 6% en Suisse romande, 5% en moyenne au niveau national, davantage en Suisse alémanique, jusqu’à 20% à Zurich par exemple, indique Francis Meyrat, qui préside depuis 13 ans l’ARMOUP, Association romande des maîtres d’ouvrage d’utilité publique. Selon lui, cela devrait changer dans le Jura.</p>
<p class=\"ekk-subheading-text\">On construira davantage d’immeubles</p>
<p class=\"ekk-normal-text\">L’aménagement du territoire va rendre plus difficile l’accès à l’habitat individuel et les immeubles vont prendre en importance. D’autant que le Jura devient attractif à l’extérieur, pour les Bâlois notamment, analyse le Jurassien, actuel maire de Rossemaison.</p>
<p class=\"ekk-normal-text\">L’ARMOUP, association faîtière romande des coopératives d’habitation, regroupe plus de 230 membres représentant plus de 24 000 logements en Suisse romande, dont 580 dans le Jura et 61 dans le Jura bernois. Elle est affiliée à l’association Coopératives d’habitation Suisse, la faîtière nationale dont Francis Meyrat est aussi le vice-président. Ce mouvement a débuté en 1919. C’était une autre époque, où le souci portait sur l’offre de logements d’une certaine qualité à prix abordable pour les ouvriers mal payés.</p>
<p class=\"ekk-subheading-text\">La philosophie demeure</p>
<p class=\"ekk-normal-text\">Les coopératives d’habitation étaient au début issues du mouvement ouvrier. Par la suite, les syndicats chrétiens ont initié leurs propres coopératives. Les milieux bourgeois s’y sont aussi mis, avec une association essentiellement alémanique, Wohnen Schweiz. Aujourd’hui, l’inspiration politique de ces mouvements coopératifs a perdu en importance.</p>
<p class=\"ekk-normal-text\">Mais la philosophie demeure. Francis Meyrat est persuadé que le mouvement a toujours du sens. Avec des loyers proches du prix coûtant, à 20% en moyenne au-dessous des prix du marché, les coopératives d’habitation freinent la spéculation immobilière. «En plus de cela, les coopératives entretiennent mieux leurs immeubles que les propriétaires particuliers. Le taux de rénovation est plus important. Et chaque locataire a droit à participer à la gestion, à entrer au comité, poser des questions sur les comptes, les travaux entrepris, etc. Il y a toujours une place pour ce type de structure. D’autant plus que les prix ont augmenté vertigineusement dans la région, malgré les taux hypothécaires bas et un taux de logements vides assez important dans le Jura.»</p>
<p class=\"ekk-subheading-text\">Le Jura devrait avoir sa loi sur le logement</p>
<p class=\"ekk-normal-text\">Selon Francis Meyrat, le canton du Jura devrait légiférer sur la politique du logement en général et sociale en particulier. Les coopératives de logement sont appelées à se développer, analyse Francis Meyrat. «Il faut pallier l’absence d’aide fédérale, avoir un contrôle sur les loyers subventionnés d’une façon ou d’une autre. Il faut pouvoir déclarer certaines zones constructibles avec des pourcentages d’utilité publique, la mise à disposition de terrains avec des règles fiscales à développer pour les organismes d’utilité publique.»</p>
<p class=\"ekk-normal-text\">Il manque un cadre pour les coopératives d’habitation, dont certaines ont connu de gros problèmes de trésorerie dans le Jura. Francis Meyrat en sait quelque chose: il a été sollicité pour sauver l’une ou l’autre société coopérative. La gestion et l’entretien des immeubles coopératifs ne sont pas toujours au top dans le canton.</p>
<p class=\"ekk-normal-text\">Jean-Paul Miserez, conseiller de ville PCSI à Delémont et actif dans le dossier de l’habitat coopératif, se dit lui aussi convaincu de l’intérêt des coopératives d’habitation au XXI<span class=\"Exposant\">e</span> siècle, avec des immeubles de qualité. «Le but est surtout de sortir des circuits spéculatifs et d’avoir une certaine autonomie de décision. On ne cherche pas à profiter du locataire pour faire du bénéfice. Il s’agit d’obtenir de la collectivité des conditions favorables, la mise à disposition de terrains, de droits de superficie à des conditions avantageuses. La même chose pour les prêts bancaires, sans exiger les garanties financières d’un promoteur habituel.»</p>
<p class=\"ekk-subheading-text\">Aide pour constituer les fonds propres</p>
<p class=\"ekk-normal-text\">Les garanties financières: voilà la force de l’ARMOUP, qui a pour mandat d’attribuer les montants mis à disposition par la Confédération au titre de l’aide au logement. Il ne s’agit pas de l’ancienne aide fédérale qui était attribuée sur une base individuelle: elle permettait de diminuer les loyers ou les intérêts au début de l’accès au logement mais l’augmentation des loyers du fait de la diminution programmée de l’aide s’est révélée un piège pour les bénéficiaires, dont on paie encore les pots cassés, lorsque le loyer devient inabordable pour les personnes concernées. Les montants confiés à l’ARMOUP dans le cadre de la Loi fédérale encourageant le logement à loyers modérés (LOG) permettent de constituer les fonds propres exigés pour les prêts bancaires et démarrer les projets immobiliers ou de rénovation.</p>
<p class=\"ekk-normal-text\">L’aide de l’ARMOUP a contribué au démarrage du dernier immeuble construit par une coopérative d’habitation dans le Jura. La Société coopérative immobilière du Cartel syndical est à l’origine de ce projet, qui couronne ses 50 ans d’existence. L’immeuble, inauguré officiellement ce printemps sur la place des Mouleurs à Courroux, compte neuf appartements.</p>
<p class=\"ekk-subheading-text\">«S’aider soi-même»</p>
<p class=\"ekk-normal-text\">À la société du Cartel syndical, chaque locataire est tenu de détenir des parts sociales, explique son président, Jean-Claude Prince. La société compte 120 associés dont 113 locataires, des artisans, particuliers acquis à la cause, deux communes et deux organisations syndicales. Pour Jean-Claude Prince, les sociétés coopératives «doivent offrir plus que du simple logement d’utilité publique: elles contribuent largement à la mise à disposition d’habitat à prix abordable pour une large couche de la population et favorisent la mixité sociale, elles exercent un rôle intégrateur et offrent à leurs locataires la sécurité du logement.» Les coopératives associent propriété privée et collective et chacun peut ainsi s’aider soi-même, analyse Jean-Claude Prince.</p>
<p class=\"ekk-normal-text\"><span class=\"SIGNATURE\"> GEORGES MAILLARD</span></p>
<h2>Une réflexion en cours avec les coopératives à Delémont</h2>
<p class=\"ekk-normal-text\">L’ARMOUP, la faîtière romande des coopératives d’habitation, compte une vingtaine de membres dans la région: 16 dans le canton du Jura et quatre dans le Jura bernois. Il faut y ajouter un petit nombre de coopératives non-membres de l’ARMOUP. Elles sont réparties dans tout le canton du Jura, avec une prépondérance dans le district de Delémont. Dans le Jura-Sud, c’est surtout à Moutier que l’on retrouve ces coopératives. Une des plus anciennes est la Société coopérative immobilière Le Vorbourg, à Delémont, constituée en 1947. Une des plus connues, la plus grande, est la Société coopérative immobilière du Cartel syndical, fondée en 1963, avec 113 logements. La création de la Société coopérative des cheminots remonte à 1956. La Société coopérative d’habitation du Cartel des syndicats chrétiens date de 1960. Mais la Société de construction et Fondation Eigenheim du personnel des entreprises de transport à Delémont a œuvré dès 1919 pour des logements à prix modérés, nous dit la Chronologie jurassienne de Denis Moine. Elle a été dissoute en 1922 déjà. La Société coopérative d’habitation du Mont-Terrible est née en 1987, la Société coopérative delémontaine d’habitation en 1994. Sept coopératives delémontaines planchent actuellement avec la ville sur des projets qui pourraient prendre forme à la rue des Moissons et à l’écoquartier Europan de Morépont. <span class=\"SIGNATURE\">GM</span></p>
</div>";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}