import re
regex = re.compile(r"(?<entropy>\d+)\s*bit\s*(?<algo>\S+)\s*key\s*(?<pubkeyid>[^,]+)", flags=re.MULTILINE)
test_str = ("gpg: data source: http://162.213.33.9:11371\n"
"(1) Ferry Huberts <hubferry@amazon.com>\n"
" 2048 bit RSA key 6E2B662831D0CC10, created: 2018-02-07\n"
"(2) 2048 bit RSA key 0BC0283EFDAEF030, created: 2018-03-10\n"
"(3) Josh Glover (Unix Systems Administrator) <jglover@amazon.com>\n"
" Josh Glover (Unix Systems Administrator) <jglover@amazon.co.jp>\n"
" 1024 bit DSA key E17F5B227E900E40, created: 2005-12-06\n"
"(4) 4096 bit RSA key 24B92E0779F635B0, created: 2015-12-23\n"
"(5) 1024 bit DSA key D7BA5D43FBF27CC0, created: 2011-01-27\n"
"(6) 4096 bit RSA key FB2FA8D887FC1DC0, created: 2017-10-04\n"
"(7) 2048 bit RSA key 190232BEA3460DD0, created: 2012-11-28\n"
"(8) Mark Caudill <markca@amazon.com>\n"
" 1024 bit DSA key 20640006F66A12E0, created: 2009-02-17\n"
"(9) Xenia Kleopatra (Xenia Kleopatra) <xllojova@amazon.com>\n"
" 2048 bit RSA key 8160348321F61431, created: 2016-03-03\n"
"(10) 4096 bit RSA key 51979A726FE02431, created: 2016-03-24\n"
"(11) MitchellCutler (This is my Public Key Certificate) <cutlermc@amazon.co\n"
" 2048 bit RSA key FE7B4D2A2CAF8A31, created: 2015-04-23\n"
"(12) Amazon Elasticache (Signing key for Elasticache maven artifacts) <aws-\n"
" 2048 bit RSA key 8E929B5B774E3E31, created: 2016-10-19\n"
"(13) 2048 bit RSA key 0A4F0C8F5B5DE981, created: 2012-05-11\n"
"(14) 1024 bit RSA key AD960C3C09043347, created: 1998-09-04\n"
"(15) Eric Brandwine <ericbran@amazon.com>\n"
" 2048 bit RSA key 605E1724D413B9D1, created: 2010-03-24\n"
"Keys 1-15 of 100 for \"amazon.com\". gpg: Sorry, we are in batchmode - can't get input")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")