$re = '/((?:\w+\.){0,}\[{0,}(`){0,}Тип заканчивания\2{0,}\]{0,})/s';
$str = 'SELECT `Тип заканчивания`, YEAR(`Дата ввода`) AS [Год] FROM [DeleteMe13$A1:B21]
GROUP BY `Тип заканчивания`';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);