$re = '/^(RACAO|ROYAL).*/m';
$str = 'RACAO ROYAL
ROYAL FDA
RACAO FAD
abc ROYAL';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);