re = /(?<=(\s|\(|\[|\{|_)):[\w\#\.\-\_\:\+\=\>\<\/\!\?\*]+(?=(\s|\)|\]|\}|\,))/m
str = '#_:foo'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end