$re = '/\B\"\b(.*?)\b\"\B/m';
$str = 'This is my "te
st" case
with lines for "tes"t"ing" with regex
But as he said "It could be an arbitray ammount of words"';
$subst = "\\q{$1}";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;