$re = '/[abc]/';
$str = 'The lion roared a bunch of times';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);