re = /(?:.*SER1.*)|(?:.*SER2.*)|(?:.*SER3.*)/m
str = 'www.abc.SER1.com
www.abc.SER2.com
www.abc.SER3.com
www.abc.SER4.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end