import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<!-- AppInternalsXpert BMX Integration Begin -->(.*[\\s\\S]*)<!-- AppInternalsXpert BMX Integration End -->";
final String string = "\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n\n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n\n"
+ " \n\n"
+ " \n"
+ " \n\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n\n"
+ " \n\n\n"
+ " \n"
+ " \n\n"
+ " \n"
+ " \n"
+ "<script>\n"
+ "$(function() {\n"
+ " $( \".tabs\" ).tabs();\n"
+ " });\n"
+ "</script>\n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n"
+ " \n\n"
+ " \n\n\n\n\n\n\n\n\n"
+ " \n"
+ " \n"
+ " \n"
+ " <!-- AppInternalsXpert BMX Integration Begin -->\n"
+ " <script>\n"
+ " if(!RVBD_EUE){\n"
+ " var RVBD_EUE={startJS:Number(new Date()),\n"
+ " clientId:'',appId:1,\n"
+ " collector:'apmperformance.correios.com.br',\n"
+ " collectorHttpPort:80, collectorHttpsPort:443,\n"
+ " sv:'0401',\n"
+ " ajax:true, sync:true,\n"
+ " ajaxResponseTime:true};\n"
+ " (function(){\n"
+ " var w=window,l=w.addEventListener,m=w.attachEvent,\n"
+ " d=document,s='script',t='load',o=RVBD_EUE,\n"
+ " r=(('https:'===d.location.protocol)?\n"
+ " 'https://apmperformance.correios.com.br:443':\n"
+ " 'http://apmperformance.correios.com.br:80')+\n"
+ " '/jsi/riverbed_appinternals.d.'+\n"
+ " (o.ajax?'ajax.js':'js'),p=('onpagehide' in w),e=p?'pageshow':t,\n"
+ " j=d.createElement(s),x=d.getElementsByTagName(s)[0],\n"
+ " h=function(y){o.ldJS=o.ldJS||new Date();o.per=y?y.persisted:null;},\n"
+ " i=function(){o.ld=1;};o.cookie=d.cookie;d.cookie=\n"
+ " '_op_aixPageId=0; path=/; expires='+(new Date(0)).toGMTString();\n"
+ " o.cookieAfterDelete=d.cookie;j.async=1;j.src=r;\n"
+ " if(l){l(e,h,false);if(p){l(t,i,false);}}else if(m)\n"
+ " {m('on'+e,h);if(p){m('on'+t,i);}}\n"
+ " if(o.sync){d.write('<'+s+' src=\\''+r+'\\'></'+s+'>');}\n"
+ " else{x.parentNode.insertBefore(j,x);}\n"
+ " })();}\n"
+ " </script>\n"
+ " <script>if(!RVBD_EUE_PARAM){var RVBD_EUE_PARAM={};} RVBD_EUE_PARAM.pageId = 'a2_e6e8c617-d7ec-4acd-a432-08b0febc30e0';</script> \n"
+ " <!-- AppInternalsXpert BMX Integration End -->\n"
+ " [cadastrado]\n"
+ " \n\n"
+ " \n"
+ " \n"
+ " \n"
+ " ";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}