package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\.[a-z]{2,}$`)
var str = `google.com
sub1.sub2.example.com
something.net`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}