import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\s|^)\\d{1,3}\\/\\s(?:(?!\\s\\d{1,3}\\/\\s)[\\s\\S])*";
final String string = "1/ This is a string and it \n"
+ "has some text on a new line\n"
+ "2/ And then there's another string that has text only on one line\n"
+ "532/ Another string that has some year on a new line \n"
+ "2020/xyz followed by some letters\n"
+ "720/ This is a match on the same line with another match but the other match won't be captured 721/ And this is the last line ";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}