import re
regex = re.compile(r"[^ ]+\b")
test_str = "I don't want any toast, and he doesn't want any toast. In fact, no-one around here wants any toast. Not now, not ever. No toast."
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")