# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<\/?html.*?>"
test_str = ("<html xmlns:v=\"urn:schemas-microsoft-com:vml\" xmlns:o=\"urn:schemas-microsoft-com:office:office\" xmlns:w=\"urn:schemas-microsoft-com:office:word\" xmlns:x=\"urn:schemas-microsoft-com:office:excel\" xmlns:m=\"http://schemas.microsoft.com/office/2004/12/omml\" xmlns=\"http://www.w3.org/TR/REC-html40\">\n"
"<head>\n"
"some head info \n"
"</head>\n"
"<body>\n"
"<div > some content with other HTML tags that I want to preserve </div>\n"
"<body>\n"
"</html>\n"
"<html>\n"
"<div> another content with other HTML tags that I want to preserve </div>\n"
"</html>\n"
"<html xmlns=\"http://www.w3.org/TR/REC-html40\">\n"
"<head>\n"
"some head info \n"
"</head>\n"
"<body>\n"
"<div> some other content with other HTML tags that I want to preserve </div>\n"
"<body>\n"
"</html>")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.