re = /Chr\.(I(?!I)|III(?!I))/m
str = 'Chr.
Chr.I
Chr.II
Chr.III
Chr.IIV
Chr.IIII.I'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end