import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?=(?:[^\\n\\d]*\\d){5})(?!(?:[^\\n\\d]*\\d){21})(?:\\(\\+\\d+\\)|\\+\\d+) ?\\d+(?:-\\d+)*$";
final String string = "(+355)250235\n"
+ "+91 123456789012\n"
+ "(+355) 250-236-236-789\n"
+ "(+355) 2502-3656-1236-8789\n"
+ "+920123456789012345987\n\n\n"
+ "(+355)2\n"
+ "+91\n"
+ "(+355) 2\n"
+ "+920123456789012345987";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}