$re = '/\$VAR(?!\d)/';
$str = '$VAR VAR $$VAR $VAR1 $VAR1$VAR$VAR2 $VAR';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);