#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)^([\d-\.\s\:]+)\s.*?-\s([\w\s:\.]+)(<\w+.*?)\n\d{4}"
Local $sString = "2018-11-25 14:10:29.184 [ajp-bio-172.27.9.196-8009-exec-1] ERROR c.q.j.c.a.event.AuditEventHandler U:UNKNOWN SC:17618 TX:0 - SesIdCode is null. So no audit log transaction for this transaction" & @CRLF & _
"2018-11-25 14:10:29.184 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.p.component.SenderComponent U:UNKNOWN SC:17618 TX:0 - SendMessage, Invockation End.." & @CRLF & _
"2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] DEBUG c.e.r.p.endpoint.PickerProcessor U:UNKNOWN SC:17618 TX:0 - Message Picked from the queue....<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">" & @CRLF & _
" <soapenv:Header />" & @CRLF & _
" <soapenv:Body>" & @CRLF & _
" <EAI_MESSAGE>" & @CRLF & _
" <EAI_HEADER>" & @CRLF & _
" <ServiceName>SMS</ServiceName>" & @CRLF & _
" <ServiceType>SendSms</ServiceType>" & @CRLF & _
" <ServiceVersion>1.0</ServiceVersion>" & @CRLF & _
" <Client>xx</Client>" & @CRLF & _
" <ClientChannel>SBA</ClientChannel>" & @CRLF & _
" <MsgChannel>WebServices</MsgChannel>" & @CRLF & _
" <SecurityInfo>" & @CRLF & _
" <Authentication>" & @CRLF & _
" <UserId>xxx</UserId>" & @CRLF & _
" <Password>xxx</Password>" & @CRLF & _
" </Authentication>" & @CRLF & _
" <Authorization>" & @CRLF & _
" <UserId>xxx</UserId>" & @CRLF & _
" </Authorization>" & @CRLF & _
" </SecurityInfo>" & @CRLF & _
" <SnapIns>" & @CRLF & _
" <NameValue Name="" Value="" />" & @CRLF & _
" </SnapIns>" & @CRLF & _
" <RequestorLanguage>E</RequestorLanguage>" & @CRLF & _
" <EaiReference>0</EaiReference>" & @CRLF & _
" <ReturnCode>0000</ReturnCode>" & @CRLF & _
" </EAI_HEADER>" & @CRLF & _
" <EAI_BODY>" & @CRLF & _
" <EAI_REQUEST>" & @CRLF & _
" <SendSmsRequest>" & @CRLF & _
" <RefID>502521</RefID>" & @CRLF & _
" <ISD>974</ISD>" & @CRLF & _
" <PhoneNO>xxx</PhoneNO>" & @CRLF & _
" <Message>Dear User, Your unique OTP pin for xxx is xxxx</Message>" & @CRLF & _
" <Language>E</Language>" & @CRLF & _
" <Priority>2</Priority>" & @CRLF & _
" <SchDate />" & @CRLF & _
" <SrcKey>xx</SrcKey>" & @CRLF & _
" <Department>xx xx</Department>" & @CRLF & _
" <SMSUser>SMS Alerter</SMSUser>" & @CRLF & _
" </SendSmsRequest>" & @CRLF & _
" </EAI_REQUEST>" & @CRLF & _
" </EAI_BODY>" & @CRLF & _
" </EAI_MESSAGE>" & @CRLF & _
" </soapenv:Body>" & @CRLF & _
"</soapenv:Envelope>" & @CRLF & _
"2018-11-25 14:10:38.666 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17618 TX:0 - Starting the processor -com.eix.processor.persistence.InPersisterProcessor" & @CRLF & _
"2018-11-25 14:27:58.099 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.w.c.i.impl.CheckInServiceImpl U:UNKNOWN SC:17740 TX:0 - Invoking webservice http://alteainterface.qatarairways.com.qa/AlteaODS/AlteaODS.svc" & @CRLF & _
"2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.w.c.i.impl.CheckInServiceImpl U:UNKNOWN SC:17740 TX:0 - Response Message : <MESSAGE><HEADER><ServiceName>xxxx xxxx</ServiceName><ServiceType>PassengerInfo</ServiceType><ServiceVersion>1.0</ServiceVersion><Client>xxx</Client><ClientChannel>xx</ClientChannel><MsgChannel>WebServices</MsgChannel><SecurityInfo><Authentication><UserId>xx</UserId><Password>xxx</Password></Authentication></SecurityInfo></HEADER><BODY><RESPONSE><passengerStatus>Invalid</passengerStatus><RegisteredFlight></RegisteredFlight><passengerPhone></passengerPhone><passengerEmail></passengerEmail><FFPNumber></FFPNumber></RESPONSE></BODY></MESSAGE>" & @CRLF & _
"2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO c.e.r.process.GenericProcessor U:UNKNOWN SC:17740 TX:0 - Starting the processor -com.eix.processor.persistence.OutPersisterProcessor" & @CRLF & _
"2018-11-25 14:27:58.178 [ajp-bio-172.27.9.196-8009-exec-1] INFO " & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")