re = /(https?\:\/\/)?(www\.)?([a-z0-9]([a-z0-9]|(\-[a-z0-9]))*\.)+[a-z]+(\/[\-a-z_]+)*(\/[a-z]+\.(jpg|png|jpeg|JPG|PNG|JPEG){1})/
str = 'http://www.laweb.es/ruta_a_la-url/delaimagen.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end