package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*intranet.corp.internal.citizensbank.com\/google\/loading.asp[?](.*)`)
var str = `http://intranet.corp.internal.citizensbank.com/google/loading.asp?http://wmgtrib00001011/onlineforms/vpn.aspx?topnav
http://intranet.corp.internal.citizensbank.com/google/loading.asp?http://docushare.corp.internal.citizensbank.com/dsweb/Get/Document-570486/?topnav
http://intranet.corp.internal.citizensbank.com/google/loading.asp?https://departments.internal.citizensbank.com/sites/CommercialBanking/SitePages/Conflicts%20Office.aspx?topnav?cmcl?conflictsoffice
http://intranet.corp.internal.citizensbank.com/google/loading.asp?https://departments.internal.citizensbank.com/sites/CommercialBanking/MT/_layouts/15/start.aspx#/Marketing Toolkit Pages/Marketing Toolkit.aspx?topnav?cmcl?mkttoolkit
http://intranet.corp.internal.citizensbank.com/google/loading.asp?https://departments.internal.citizensbank.com/sites/CTS/Wiki_Library/DaaS%20Virtual%20Desktop.aspx?topnav?daas
http://intranet.corp.internal.citizensbank.com/google/loading.asp?http://wiisrib00001317:8300/RedirectPage.aspx?topnav?matchgifts
http://intranet.corp.internal.citizensbank.com/google/loading.asp?http://docushare.corp.internal.citizensbank.com/dsweb/Get/Document-611169/?feature?hr?mobile
http://intranet.corp.internal.citizensbank.com/google/loading.asp?https://departments.internal.citizensbank.com/sites/TransformationPDO/SitePages/Home.aspx?topnav
http://intranet.corp.internal.citizensbank.com/google/loading.asp?http://investor.citizensbank.com/about-us/our-company/leadership/board-of-directors.aspx?mobile
http://intranet.corp.internal.citizensbank.com/google/loading.asp?https://departments.internal.citizensbank.com/sites/CommercialBanking/PC/default.aspx?topnav?cmcl?trainingdev
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}