import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?|(\\[[\\\"]?.+?[\\\"]?\\])(=>)\\R\\s*|(?<=\\(0\\) )(\\{)\\R\\s*(\\}))";
final String string = "object(Symfony\\Component\\HttpFoundation\\Request)#250 (21) {\n"
+ " [\"attributes\"]=>\n"
+ " object(Symfony\\Component\\HttpFoundation\\ParameterBag)#253 (1) {\n"
+ " [\"parameters\":protected]=>\n"
+ " array(5) {\n"
+ " [\"_controller\"]=>\n"
+ " object(Closure)#239 (2) {\n"
+ " [\"static\"]=>\n"
+ " array(1) {\n"
+ " [\"app\"]=>\n"
+ " object(Silex\\Application)#14 (8) {\n"
+ " [\"providers\":protected]=>\n"
+ " array(5) {\n"
+ " [0]=>\n"
+ " object(Silex\\Provider\\HttpKernelServiceProvider)#17 (0) {\n"
+ " }\n"
+ " [1]=>\n"
+ " object(Silex\\Provider\\RoutingServiceProvider)#26 (0) {\n"
+ " }\n"
+ " [2]=>\n"
+ " object(Silex\\Provider\\ExceptionHandlerServiceProvider)#36 (0) {\n"
+ " }\n"
+ " [3]=>\n"
+ " object(Silex\\Provider\\TwigServiceProvider)#38 (0) {\n"
+ " }\n"
+ " [4]=>\n"
+ " object(Euskadi31\\Silex\\Provider\\CorsServiceProvider)#54 (0) {\n"
+ " }\n"
+ " }\n"
+ " [\"booted\":protected]=>\n"
+ " bool(true)\n"
+ " [\"values\":\"Pimple\\Container\":private]=>\n"
+ " array(37) {\n"
+ " [\"request.http_port\"]=>\n"
+ " int(80)\n"
+ " [\"request.https_port\"]=>\n"
+ " int(443)\n"
+ " [\"debug\"]=>\n"
+ " bool(true)\n"
+ " [\"charset\"]=>\n"
+ " string(5) \"UTF-8\"\n"
+ " [\"logger\"]=>\n"
+ " NULL\n"
+ " [\"resolver\"]=>\n"
+ " object(Symfony\\Component\\HttpKernel\\Controller\\ControllerResolver)#307 (1) {\n"
+ " [\"logger\":\"Symfony\\Component\\HttpKernel\\Controller\\ControllerResolver\":private]=>\n"
+ " NULL\n"
+ " }\n"
+ " [\"argument_metadata_factory\"]=>\n"
+ " object(Symfony\\Component\\HttpKernel\\ControllerMetadata\\ArgumentMetadataFactory)#301 (0) {\n"
+ " }\n"
+ " [\"argument_value_resolvers\"]=>\n"
+ " array(5) {\n"
+ " [0]=>\n"
+ " object(Silex\\AppArgumentValueResolver)#298 (1) {\n"
+ " [\"app\":\"Silex\\AppArgumentValueResolver\":private]=>\n"
+ " *RECURSION*\n"
+ " }\n"
+ " [1]=>\n"
+ " object(Symfony\\Component\\HttpKernel\\Controller\\ArgumentResolver\\RequestAttributeValueResolver)#295 (0) {\n"
+ " }\n"
+ " [2]=>\n"
+ " object(Symfony\\Component\\HttpKernel\\Controller\\ArgumentResolver\\RequestValueResolver)#292 (0) {\n"
+ " }\n"
+ " [3]=>\n"
+ " object(Symfony\\Component\\HttpKernel\\Controller\\ArgumentResolver\\DefaultValueResolver)#289 (0) {\n"
+ " }\n"
+ " [4]=>\n"
+ " object(Symfony\\Component\\HttpKernel\\Controller\\ArgumentResolver\\VariadicValueResolver)#286 (0) {\n"
+ " }\n"
+ " }";
final String subst = "\\1 \\2";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}