#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[^\d]?(?:(\d\d)[^\d]?(\d\d)[^\d]?(\d\d)(\.[\d\w]{1,}){0,1})(.*)$"
Local $sString = "123456.123abc" & @CRLF & _
                "00 24 13.13456789 Scopes of Bids (Multiple Contracts) " & @CRLF & _
                "00 24 13.16 Scopes of Bids (Multiple-Prime Contract) " & @CRLF & _
                "00 00 00 Procurement and Contracting Requirements " & @CRLF & _
                "00 01 01 Project Title Page " & @CRLF & _
                "00 01 05 Certifications Page " & @CRLF & _
                "00 01 07 Seals Page " & @CRLF & _
                "00 01 10 Table of Contents " & @CRLF & _
                "00 01 15 List of Drawing Sheets " & @CRLF & _
                "00 01 20 List of Schedules " & @CRLF & _
                "00 10 00 Solicitation " & @CRLF & _
                "00 11 00 Advertisements and Invitations " & @CRLF & _
                "00 11 13 Advertisement for Bids " & @CRLF & _
                "00 11 16 Invitation to Bid " & @CRLF & _
                "00 11 19 Request for Proposal " & @CRLF & _
                "00 11 53 Request for Qualifications " & @CRLF & _
                "00 20 00 Instructions for Procurement " & @CRLF & _
                "00 21 00 Instructions " & @CRLF & _
                "00 21 13 Instructions to Bidders " & @CRLF & _
                "00 21 16 Instructions to Proposers " & @CRLF & _
                "00 22 00 Supplementary Instructions " & @CRLF & _
                "00 22 13 Supplementary Instructions to Bidders " & @CRLF & _
                "00 22 16 Supplementary Instructions to Proposers " & @CRLF & _
                "00 23 00 Procurement Definitions " & @CRLF & _
                "00 24 00 Procurement Scopes " & @CRLF & _
                "00 24 13 Scopes of Bids "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
    _ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")