import re
regex = re.compile(r"(.?(?:FROM)\ [a-zA-Z_]+(?:\.[a-zA-Z_]+)?)")
test_str = ("SELECT sl.subscription_link_id link_data_id\n"
" , sl.subscription_id link_sub_id\n"
" , a.adoption_id link_id\n"
" , a.date_created link_start_date\n"
" , dispatches.bill_charge_id link_charge_id\n"
" , dispatches.total_amount link_amount\n"
" , dispatches.status link_charge_status\n"
" , dispatches.date_created link_charge_date_created\n"
" , dispatches.date_modified link_charge_date_modified\n"
" , dispatches.bill_fin_instrument_id charge_bill_fin_instrument_id\n"
" , dispatches.date_resolved charge_resolved\n"
" , dispatches.lp_exp_date charge_lp_exp_date\n"
" , a.date_modified link_date_modified\n"
" , a.date_created link_date_created\n"
" , dispatches.base_price_type_id link_base_price_type_id\n"
" , dispatches.status link_bill_charge_status\n"
" , CASE\n"
" WHEN ls.exp_date IS NOT NULL\n"
" THEN ls.exp_date\n"
" ELSE add_months(l.date_created, lp.num1 * DECODE(lp.num2,1,12,2,1) )\n"
" END link_end_date\n"
" , CASE\n"
" WHEN ls.exp_date IS NOT NULL\n"
" THEN 1\n"
" ELSE (lp.num1 * DECODE(lp.num2,1,12,2,1,5,0,0))\n"
" END link_term\n"
"FROM emetadata.ers_subscription_links sl\n"
" , emetadata.ers_adoptions a\n"
" , emetadata.ers_adopt_fulfillments af\n"
" , emetadata.ers_licenses l\n"
" , emetadata.ers_license_parameters lp\n"
" , emetadata.ers_license_slots ls\n"
" , (SELECT adopt_charge.bill_charge_id\n"
" , adopt_charge.status\n"
" ,adopt_charge.total_amount\n"
" , partitions.date_resolved\n"
" ,partitions.lp_exp_date\n"
" , adopt_charge.adoption_id\n"
" ,adopt_charge.date_created\n"
" , adopt_charge.date_modified\n"
" , adopt_charge.bill_fin_instrument_id\n"
" , adopt_charge.base_price_type_id\n"
" FROM\n"
" (SELECT bc.bill_charge_id\n"
" , bc.status\n"
" , bc.date_created\n"
" , bc.date_modified\n"
" , bc.total_amount\n"
" , bc.bill_fin_instrument_id\n"
" , acl.adoption_id\n"
" ,oicl.base_price_type_id\n"
" FROM emetadata.ersmd_adoption_charge_link acl\n"
" , emetadata.ers_bill_charge bc\n"
" , emetadata.ers_order_charge_links oicl\n"
" WHERE acl.charge_id = bc.bill_charge_id AND oicl.bill_charge_id = bc.bill_charge_id\n"
" ) adopt_charge\n"
" , (SELECT pcl.bill_charge_id\n"
" , bd.date_resolved\n"
" , cpi.lp_exp_date\n"
" FROM emetadata.ers_bill_dispatches bd\n"
" , emetadata.ers_charge_partitions cp\n"
" , emetadata.ersmd_charge_partition_info cpi\n"
" , emetadata.ers_part_charge_link pcl\n"
" WHERE cp.charge_partition_id = bd.charge_partition_id (+) AND cp.charge_partition_id=cpi.charge_partition_id(+) AND cp.charge_partition_id =\n"
" pcl.charge_partition_id AND cp.status = 3\n"
" ) partitions\n"
" WHERE adopt_charge.bill_charge_id = partitions.bill_charge_id (+)\n"
" ) dispatches\n"
"WHERE a.subscription_link_id = sl.subscription_link_id AND af.adoption_id = a.adoption_id AND a.adoption_id = dispatches.adoption_id (+) AND\n"
" af.fulfillment_target_id = l.license_id AND l.license_id = lp.license_id AND l.license_id = ls.license_id (+);\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")