# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\"text\": \")(.*?hello.*?)(?=\", \"type\": \"text\")"
test_str = ("{\"root\": {\"type\": \"root\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"type\": \"paragraph\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"mode\": \"normal\", \"text\": \"text1 hello text\", \"type\": \"text\", \"style\": \"\", \"detail\": 0, \"format\": 0, \"version\": 1}], \"direction\": \"ltr\"}], \"direction\": \"ltr\"}} hellocat world f\n\n"
"{\"root\": {\"type\": \"root\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"type\": \"paragraph\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"src\": \"https://images.unsplash.com/photo-1458966480358-a0ac42de0a7a?crop=entropy&cs=tinysrgb&fit=max&fm=jpg&ixid=M3w1MjU5NTl8MHwxfHNlYXJjaHwzfHx0cmVlfGVufDB8fHx8MTcxMzk5MjE4OHww&ixlib=rb-4.0.3&q=80&w=1080\", \"type\": \"image\", \"width\": 332, \"height\": \"221.329875\", \"version\": 1, \"alt_text\": \"image\", \"max_width\": 500}, {\"mode\": \"normal\", \"text\": \"dsadsa\", \"type\": \"text\", \"style\": \"\", \"detail\": 0, \"format\": 0, \"version\": 1}], \"direction\": \"ltr\"}, {\"type\": \"paragraph\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"mode\": \"normal\", \"text\": \"fdsfds\", \"type\": \"text\", \"style\": \"\", \"detail\": 0, \"format\": 0, \"version\": 1}], \"direction\": \"ltr\"}], \"direction\": \"ltr\"}}\n\n"
"{\"root\": {\"type\": \"root\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"type\": \"paragraph\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"mode\": \"normal\", \"text\": \"nccccchello ddddd\", \"type\": \"text\", \"style\": \"\", \"detail\": 0, \"format\": 0, \"version\": 1}], \"direction\": \"ltr\"}], \"direction\": \"ltr\"}}\n\n"
"{\"root\": {\"type\": \"root\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"tag\": null, \"type\": \"paragraph\", \"start\": null, \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"rel\": null, \"src\": null, \"url\": null, \"mode\": \"normal\", \"text\": \"bvcbvc\", \"type\": \"text\", \"style\": \"\", \"title\": null, \"value\": null, \"width\": null, \"detail\": 0, \"format\": 0, \"height\": null, \"indent\": null, \"inline\": null, \"target\": null, \"checked\": null, \"version\": 1, \"alt_text\": null, \"children\": null, \"equation\": null, \"field_id\": null, \"direction\": null, \"max_width\": null, \"field_name\": null, \"field_type\": null, \"highlight_type\": null, \"hidden_field_name\": null, \"hidden_field_value\": null}], \"language\": null, \"video_id\": null, \"direction\": \"ltr\", \"list_type\": null}], \"direction\": \"ltr\"}}\n\n\n"
"{\"root\": {\"type\": \"root\", \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"tag\": null, \"type\": \"paragraph\", \"start\": null, \"format\": \"\", \"indent\": 0, \"version\": 1, \"children\": [{\"rel\": null, \"src\": null, \"url\": null, \"mode\": \"normal\", \"text\": \"gbfbvc\", \"type\": \"text\", \"style\": \"\", \"title\": null, \"value\": null, \"width\": null, \"detail\": 0, \"format\": 0, \"height\": null, \"indent\": null, \"inline\": null, \"target\": null, \"checked\": null, \"version\": 1, \"alt_text\": null, \"children\": null, \"equation\": null, \"field_id\": null, \"direction\": null, \"max_width\": null, \"field_name\": null, \"field_type\": null, \"highlight_type\": null, \"hidden_field_name\": null, \"hidden_field_value\": null}], \"language\": null, \"video_id\": null, \"direction\": \"ltr\", \"list_type\": null}], \"direction\": \"ltr\"}}")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.