$re = '/\B(?=(\d{3})+(?!\d))/m';
$str = 'This is your monthly salary: 1200USD';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);