package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[\t ]*var\s\w*\s*=\s*.*;`)
var str = ` var toto = new string();`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}