re = /(?=.*\baprender\b)(?=.*\binvestir\b)(?=.*\bword\b).* /mi
str = 'aprender a investir na bolsa teste word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end