$re = '/^\/(?<body>.*)\/(?<flags>[gmiyus]*)$/m';
$str = '/foo\\\\/mgi/gis
/foo\\\\/mgi
foo\\\\/mgi
/foo\\\\bar/
/foo\\\\bar
/foo\\\\/
/foo\\/
/foo\\
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);