$re = '/^\d{0,2}(?:\.\d)?$/m';
$str = '2.5
12.5
.5
1
.25
123.5
1.55';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);