$re = '/,(?=[^}]*(?:,|$))/m';
$str = '"Key1"=123,"Key2"="abc","key3"={"subkey1"=12,"subkey2"="cd"},"key4"=456';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);