re = /(?P<output>.*)\s(?P<active>\w*connected)/
str = 'HDMI-1 disconnected (normal left inverted right x axis y axis)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end