re = /-([^-]+)-\1-lll$/m
str = 'mya!phaNum3rics-456-456-lll
zzzz-6a6-6a6-lll
vvvv-4-4-lll
zasdfdf-zadezz-6a6-6a6-lll'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end