const regex = /^(?:(?:\(?(?:00|\+)([1-4]\d\d|[1-9]\d+)\)?)[\-\.\ \\\/]?)?((?:\(?\d{1,}\)?[\-\.\ \\\/]?)+)(?:[\-\.\ \\\/]?(?:#|ext\.?|extension|x)[\-\.\ \\\/]?(\d+))?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:\\(?(?:00|\\+)([1-4]\\d\\d|[1-9]\\d+)\\)?)[\\-\\.\\ \\\\\\\/]?)?((?:\\(?\\d{1,}\\)?[\\-\\.\\ \\\\\\\/]?)+)(?:[\\-\\.\\ \\\\\\\/]?(?:#|ext\\.?|extension|x)[\\-\\.\\ \\\\\\\/]?(\\d+))?$', 'gm')
const str = `(+351) 282 43 50 50
(123)8575973`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}