import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\d: (?!<)[^\\n]+(?:\\n .*)*";
final String string = "1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue qlen 1\n"
+ " link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00\n"
+ " inet 127.0.0.1/8 scope host lo\n"
+ " valid_lft forever preferred_lft forever\n"
+ " inet6 ::1/128 scope host \n"
+ " valid_lft forever preferred_lft forever\n"
+ "2: lan1: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc mq qlen 1000\n"
+ " link/ether 00:60:e0:6a:48:26 brd ff:ff:ff:ff:ff:ff\n"
+ " inet 10.32.39.55/24 brd 10.32.39.255 scope global lan1\n"
+ " valid_lft forever preferred_lft forever\n"
+ "3: lan2: <BROADCAST,MULTICAST,UP,LOWER_UP8000> mtu 1500 qdisc mq qlen 1000\n"
+ " link/ether 00:60:e0:6a:48:27 brd ff:ff:ff:ff:ff:ff\n"
+ " inet 192.168.90.1/20 brd 192.168.95.255 scope global lan2\n"
+ " valid_lft forever preferred_lft forever\n"
+ "4: sit0@NONE: <NOARP> mtu 1480 qdisc noop qlen 1\n"
+ " link/sit 0.0.0.0 brd 0.0.0.0\n"
+ "6: wwp0s29u1u3i12: <BROADCAST,MULTICAST,NOARP,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast qlen 1000\n"
+ " link/ether 00:00:11:12:13:14 brd ff:ff:ff:ff:ff:ff\n"
+ " inet 172.16.224.124/16 brd 172.16.255.255 scope global wwp0s29u1u3i12\n"
+ " valid_lft forever preferred_lft forever";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}