package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^((?:[^\.]*\.[^\.]*){,2}|(?:[^\.]*\.[^\.]*){4,})$`)
var str = `XX.XX.XX.XX
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}