// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)(href|title)="([^"]+)""#).unwrap();
let string = "<a href=\"/kontrolno-izmeritelnyie-priboryi\" itemprop=\"item\" title=\"Контрольно-измерительные приборы\" class=\"breadcrumbs__item-link\" data-v-71>";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}