const regex = /(?<=^\.([^.]+)\..*?)\//g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=^\\.([^.]+)\\..*?)\\\/', 'g')
const str = `.PMC.89569XX/90051XX/90204XX/89533XX/90554XX/90053XX/90215XX/89874XX/89974XX/90481XX/90221XX/90508XX/90183XX/88526XX/89843XX/88041XX/90446XX/88515XX/89574XX/89847XX/88616XX/90513XX/90015XX/90334XX/89649XX.T00`;
const subst = `$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);