# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:.*?;){6}(?'champs1'.*?);\"(?'champs2'.*?)\";(?:.*?;){6}\"(?'champs5'.*?)\";(?:.*?;)\"(?'champs4'.*?)\";\"(?'champs3'.*?)\";"
test_str = "\"I01.00.00\";\"005291\";\"CG45\";\"15085\";\"cnt_ext\";\"1905151405\";181349;\"CE_11\";\"DYER Isabelle\";\"02 38 25 40 72\";003;\"Non\";\"site_ext\";\"COLLEGE VAL DE LOIRE\";\"SIT_036\";\"COLLEGE VAL DE LOIRE\";\"[Dem : 1905151405] DYSFONCTIONNEMENT PORTE EXTERIEURE PRES DE LA SALLE\";\"28/05/2019 00:00\";\"CASTELLI Olivier\";\"02 38 49 20 00\";\"\";\"olivier.castelli1@ac-orleans-tours.fr\";\"28/05/2019 00:00\";0;\"r�soudre le dysfonctionnement de la porte ext�rieure � proximit� de la salle polyvalente. K151405\""
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.