package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(\w{2,}(\.\w{3}|)\.(ir))$`)
var str = `gfhghgjhgjhgjhjghjgj.uiu.ir`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}