import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*([^#][\\w\\d_-]+?)\\[]\\s*=\\s*(\\d+[\\.,]\\d+)\\s*$";
final String string = "; This is a sample configuration file\n"
+ "; Comments start with ';', as in php.ini\n\n"
+ "[first_section]\n"
+ "one = 1\n"
+ "one = 3\n"
+ "one-two = 4\n"
+ "one_three = 3\n"
+ "five = 5.2\n"
+ "animal = BIRD\n\n"
+ "[first_section]\n"
+ "second_section[one] = \"1 associated\"\n"
+ "second_section[two] = \"2 associated\"\n"
+ "second_section[] = \"1 unassociated\"\n"
+ "second_section[] = \"2 unassociated\"\n"
+ "second_section[] = 1\n"
+ "second_section[] = 1,3\n"
+ "second_section[] = 2,2\n\n\n"
+ "[second_section]\n"
+ "path = \"/usr/local/bin\"\n"
+ "URL = \"http://www.example.com/~username\"\n"
+ "second_section[one] = \"1 associated\"\n"
+ "second_section[two] = \"2 associated\"\n"
+ "second_section[three] = 3\n"
+ "second_section[four] = 4.4\n"
+ "second_section[] = \"1 unassociated\"\n"
+ "second_section[] = \"2 unassociated\"\n"
+ "second_section[] = 1\n"
+ "second_section[] = 2.2\n\n"
+ "[third_section]\n"
+ "phpversion[] = \"5.0\"\n"
+ "phpversion[] = \"5.1\"\n"
+ "phpversion[] = \"5.2\"\n"
+ "phpversion[] = \"5.3\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}