// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(.{1,24})(?: (.{1,30}))?$").unwrap();
let string = "1 Apple Park Way. Cupertino, CA 95014
1600 Amphitheatre Parkway Mountain View, CA 94043
123456789012345678901234567890123456789012345678901234
123456789012345678901234
12345678901234 123456789012345678901234567890";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}