#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*\bgetHouseName:\h+(.+)(?:\R(?!.*price).*)*\R.*price\h+\(in doll\)\h+\[min:\h+(\d+),\h+max:\h+(\d+)\](?:\R(?!.*squaremtr).*)*\R.*squaremtr\h+\(in doll\)\h+\[min: (\d+),\h+max:(\d+)\](?:\R(?!.*sellVal).*)*\R.*sellVal\h+\(in doll\)\h+\[min:\h+(\d+),\h+max:\h+(\d+)\](?:\R(?!.*rentPrice).*)*\R.*rentPrice\(in doll\)\h+\[min: (\d+),\h+max:\h+(\d+)\]" & @CRLF & _
""
Local $sString = "[04:04:04s] [startedRetrieving]getHouseName: house1" & @CRLF & _
"[04:04:04s] [startedRetrieving]random useless text" & @CRLF & _
"[04:04:04s] [startedRetrieving]price (in doll) [min: 1000, max: 1200]" & @CRLF & _
"[04:04:05s] [startedRetrieving]squaremtr (in doll) [min: 75, max:85]" & @CRLF & _
"[04:04:04s] [startedRetrieving]sellVal (in doll) [min: 1000, max: 1200]" & @CRLF & _
"[04:04:05s] [startedRetrieving]random useless text" & @CRLF & _
"[04:04:05s] [startedRetrieving]random useless text" & @CRLF & _
"[04:04:05s] [startedRetrieving]random useless text" & @CRLF & _
"[04:04:05s] [startedRetrieving]rentPrice(in doll) [min: 150, max: 200]" & @CRLF & _
"[04:06:04s] [startedRetrieving]getHouseName: house2" & @CRLF & _
"[04:06:04s] [startedRetrieving]price(in doll) [min: 1004, max 1100]" & @CRLF & _
"[04:06:04s] [startedRetrieving]squaremtr(in doll) [min: 85, max 99]" & @CRLF & _
"[04:06:04s] [startedRetrieving]sellVal(in doll) [min: 950, max: 1050]" & @CRLF & _
"[04:06:04s] [startedRetrieving]random useless text" & @CRLF & _
"[04:06:04s] [startedRetrieving]rentPrice(in doll) [min: 150, max: 290]" & @CRLF & _
"[04:09:04s] [startedRetrieving]getHouseName: house3" & @CRLF & _
"[04:09:04s] [startedRetrieving]price(in doll) [min: 1099, max: 1200]" & @CRLF & _
"[04:09:04s] [startedRetrieving]squaremtr(in doll) [min: 90, max: 110]" & @CRLF & _
"[04:09:04s] [startedRetrieving]random useless text" & @CRLF & _
"[04:09:04s] [startedRetrieving]random useless text" & @CRLF & _
"[04:09:04s] [startedRetrieving]sellVal(in doll) [min: 1100, max: 1300]" & @CRLF & _
"[04:09:04s] [startedRetrieving]random useless text" & @CRLF & _
"[04:09:04s] [startedRetrieving]rentPrice(in doll) [min: 199, max: 300]"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")