import Foundation
let pattern = #"SDDFF"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<Rows><Row><Attributes><Column><Name>ID</Name><Value>1111</Value></Column><Column><Name>Number</Name><Value>2222</Value></Column><Column><Name>Type</Name><Value>Solution Changed</Value></Column><Column><Name>Date</Name><Value>12/11/2020 8:01:22 AM</Value></Column><Column><Name>Operator</Name><Value>problem</Value></Column><Column><Name>Description</Name><Value>Solution changed from </Value></Column><Column><Name>VisibleToCustomer</Name><Value>N</Value></Column></Attributes></Row><Row><Attributes><Column><Name>ID</Name><Value>33333</Value></Column><Column><Name>Number</Name><Value>555</Value></Column><Column><Name>Type</Name><Value>Resolved Time Changed</Value></Column><Column><Name>Date</Name><Value>12/11/2020 8:01:22 AM</Value></Column><Column><Name>Operator</Name><Value>problem</Value></Column><Column><Name>Description</Name><Value>Resolved Time changed</Value></Column><Column><Name>VisibleToCustomer</Name><Value>N</Value></Column></Attributes></Row><Row><Attributes><Column><Name>ID</Name><Value>888888</Value></Column><Column><Name>Number</Name><Value>6677</Value></Column><Column><Name>Type</Name><Value>Updated By Changed</Value></Column><Column><Name>Date</Name><Value>12/11/2020 8:01:22 AM</Value></Column><Column><Name>Operator</Name><Value>problem</Value></Column><Column><Name>Description</Name><Value>Updated By changed from</Value></Column><Column><Name>VisibleToCustomer</Name><Value>N</Value></Column></Attributes></Row></Rows>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)