# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<claim_number>\d{10,50})(\s+)(?P<ID>\d{1,10})(\s+)(?P<feature_type>[a-z-]{2,50})?(\s+)(?P<loss_location>(\w[.'\s#\/;@`&\w,%\-]*)+)?(?P<state>[a-zA-Z]{2,5})?(\s+)(?P<status>[a-zA-Z]{1})?(\s+)[$]?(?P<feature_reserve>[+-]?(\d*(,\d+)*(.)(\d+)))?(\s+)[$]?(?P<feature_paid>[+-]?(\d*(,\d+)*(.)(\d+)))?(\s+)[$]?(?P<alae_reserve>[+-]?(\d*(,\d+)*(.)(\d+)))?(\s+)[$]?(?P<alae_paid>[+-]?(\d*(,\d+)*(.)(\d+)))?(\s+)"
test_str = ("Loss Run Report KUHNLE BROTHERS, INC. Evaluation Date: 6/7/2018\n\n"
"Company: 01 NATIONAL INTERSTATE INS CO Account Number: 4000010531 Broker: NATIONAL RISK MANAGEMENT SERV.\n\n"
"Date of \n"
"Loss\n\n"
"Report \n"
"Date File Number ID Type\n\n"
" \n"
"Location of Loss\n\n"
" \n"
"ST\n\n"
" \n"
"Status\n\n"
"Claimant Driver Facts of Loss Loss Reserve Loss Paid Exp Reserve Exp Paid Total Incurred\n\n"
"Start: Policy Number: CAT001053100 Policy Term: 9/1/2012 to 9/1/2013\n\n"
"Auto Liability\n\n"
"11/20/2012 12/12/2012 000001123777 3 PD AUBURN RD - CONCORD \n"
"TOWNSHIP, OH\n\n"
"OH C 0.00 2,102.24 0.00 85.00 2,187.24\n\n"
"FRIEDRICH, PAMELA ADAM FREDERICK IV HIT OV OCCURRENCE: \n\n"
"2/14/2013 2/15/2013 000001129136 1 PD I-77 - BECKLEY, WV WV C 0.00 0.00 0.00 0.00 0.00\n\n"
"KUHNLE BROTHERS, \n"
"INC. 14905 CROSS \n"
"CREEK PARKWAY\n\n"
"U U IV ROLLED OCCURRENCE: \n\n\n"
"WEST VIRGINIA \n"
"PARKWAY AUTH \n"
"3310 PIEDMONT ROAD\n\n"
"U U IV ROLLED OCCURRENCE: \n\n"
"2/14/2013 2/15/2013 000001129136 3 PD I-77 - BECKLEY, WV WV C 0.00 1,410.00 0.00 0.00 1,410.00\n\n"
"EMERGENCY \n"
"RESPONSE & TRAIN \n"
"PO BOX 72333\n\n"
"U U IV ROLLED OCCURRENCE: \n\n"
"2/14/2013 2/15/2013 000001129136 4 PD I-77 - BECKLEY, WV WV C 0.00 7,001.22 0.00 0.00 7,001.22\n\n"
"EVERGREEN \n"
"ENVIRONMENTAL \n"
"PO BOX 1051\n\n"
"U U IV ROLLED OCCURRENCE: \n\n"
"6/10/2013 6/19/2013 000001140425 3 PD U - U, NY NY C 0.00 0.00 0.00 0.00 0.00\n\n"
"BOWERS, ALLISON JAMES COX IV & OV COLLIDED OCCURRENCE: \n\n"
"6/10/2013 6/19/2013 000001140425 4 BI U - U, NY NY C 0.00 0.00 0.00 1,100.08 1,100.08\n\n"
"VOVK, SERGEY A JAMES COX IV & OV COLLIDED OCCURRENCE: \n\n"
"7/12/2013 7/23/2013 000001143316 3 PD OHIO TURNPIKE @ EXIT 142 - \n"
"U, OH\n\n"
"OH C 0.00 6,737.49 0.00 14,876.35 21,613.84\n\n"
"SNIDER, MICHAEL JOHN MORRISON WORD VS WORD OCCURRENCE: \n\n"
"7/19/2013 8/23/2013 000001145903 4 PD HWY 75 NB - CINCINNATI, OH OH C 0.00 0.00 0.00 0.00 0.00\n\n"
"DAVIS, DENISE JOHN MARTIN INSURED REARENDED CLAIMANT OCCURRENCE: \n\n"
"Subtotal 0.00 22,885.16 0.00 16,061.43 38,946.59\n\n"
"Page 1 of 7 Confidential - Property of National Interstate 6/8/2018\n\n\n\n"
"Loss Run Report KUHNLE BROTHERS, INC. Evaluation Date: 6/7/2018\n\n"
"Company: 01 NATIONAL INTERSTATE INS CO Account Number: 4000010531 Broker: NATIONAL RISK MANAGEMENT SERV.\n\n"
"Date of \n"
"Loss\n\n"
"Report \n"
"Date File Number ID Type\n\n"
" \n"
"Location of Loss\n\n"
" \n"
"ST\n\n"
" \n"
"Status\n\n"
"Claimant Driver Facts of Loss Loss Reserve Loss Paid Exp Reserve Exp Paid Total Incurred\n\n"
"Auto Physical Damage\n\n"
"2/14/2013 2/15/2013 000001129136 1 COLL I-77 - BECKLEY, WV WV C 0.00 0.00 0.00 0.00 0.00\n\n"
"KUHNLE BROTHERS, \n"
"INC. 14905 CROSS \n"
"CREEK PARKWAY\n\n"
"U U IV ROLLED OCCURRENCE: \n\n"
"6/10/2013 6/19/2013 000001140425 1 COLL U - U, NY NY C 0.00 0.00 0.00 0.00 0.00\n\n"
"KUHNLE BROTHERS, \n"
"INC. 14905 CROSS \n"
"CREEK PARKWAY\n\n"
"JAMES COX IV & OV COLLIDED OCCURRENCE: \n\n"
"7/19/2013 8/23/2013 000001145903 1 COLL HWY 75 NB - CINCINNATI, OH OH C 0.00 0.00 0.00 0.00 0.00\n\n"
"KUHNLE BROTHERS, \n"
"INC. 14905 CROSS \n"
"CREEK PARKWAY\n\n"
"JOHN MARTIN INSURED REARENDED CLAIMANT OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: CAT001053100 Policy Term: 9/1/2012 to 9/1/2013 0.00 22,885.16 0.00 16,061.43 38,946.59\n\n"
"Start: Policy Number: EXT001053100 Policy Term: 9/1/2012 to 9/1/2013\n\n"
"000000000000 0 NOTHING TO REPORT 0.00 0.00 0.00 0.00 0.00\n\n"
"OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: EXT001053100 Policy Term: 9/1/2012 to 9/1/2013 0.00 0.00 0.00 0.00 0.00\n\n"
"Start: Policy Number: GLT001053100 Policy Term: 9/1/2012 to 9/1/2013\n\n"
"000000000000 0 NOTHING TO REPORT 0.00 0.00 0.00 0.00 0.00\n\n"
"OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: GLT001053100 Policy Term: 9/1/2012 to 9/1/2013 0.00 0.00 0.00 0.00 0.00\n\n"
"Start: Policy Number: CAT001053101 Policy Term: 9/1/2013 to 9/1/2014\n\n"
"Page 2 of 7 Confidential - Property of National Interstate 6/8/2018\n\n\n\n"
"Loss Run Report KUHNLE BROTHERS, INC. Evaluation Date: 6/7/2018\n\n"
"Company: 01 NATIONAL INTERSTATE INS CO Account Number: 4000010531 Broker: NATIONAL RISK MANAGEMENT SERV.\n\n"
"Date of \n"
"Loss\n\n"
"Report \n"
"Date File Number ID Type\n\n"
" \n"
"Location of Loss\n\n"
" \n"
"ST\n\n"
" \n"
"Status\n\n"
"Claimant Driver Facts of Loss Loss Reserve Loss Paid Exp Reserve Exp Paid Total Incurred\n\n"
"Auto Liability\n\n"
"9/5/2013 11/18/2014 000001186210 3 PD RT 81 S/B @ MM 55.2 - U, VA VA C 0.00 0.00 0.00 0.00 0.00\n\n"
"JOVIC, MILOS MARK MILLER TIRE BLOWOUT OCCURRENCE: \n\n"
"10/25/2013 10/25/2013 000001151696 3 PD S/B RT 83 - HARRISBURG, PA PA C 0.00 0.00 0.00 0.00 0.00\n\n"
"U U CLIFF KUDLACK INSURED VEHICLE HIT OBJECT OCCURRENCE: \n\n"
"10/28/2013 10/28/2013 000001151900 2 BI RT 306 AND BELL ST6 - SOUTH \n"
"RUSSELL, OH\n\n"
"OH C 0.00 135,000.00 0.00 0.00 135,000.00\n\n"
"MILLER, MARIELLEN EDWARD \n"
"KRASOUSKY\n\n"
"IV HIT OV OCCURRENCE: \n\n"
"10/28/2013 10/28/2013 000001151900 2 PD RT 306 AND BELL ST6 - SOUTH \n"
"RUSSELL, OH\n\n"
"OH C 0.00 10,406.87 0.00 0.00 10,406.87\n\n"
"MILLER, MARIELLEN EDWARD \n"
"KRASOUSKY\n\n"
"IV HIT OV OCCURRENCE: \n\n"
"11/13/2013 11/18/2013 000001153640 3 PD RTE 45 & LINCOLN - SALEM, \n"
"OH\n\n"
"OH C 0.00 0.00 0.00 0.00 0.00\n\n"
"BUTLER \n"
"REFRIGERATED \n"
"MEATS\n\n"
"JOHN BOROS RECORD ONLY OCCURRENCE: \n\n"
"11/21/2013 11/21/2013 000001154099 3 PD SPRU PARKING LOT - \n"
"NISKAYUNA, NY\n\n"
"NY C 0.00 1,817.16 0.00 0.00 1,817.16\n\n"
"BONCELLA, JOHN TAMMY \n"
"ZIMMERMAN\n\n"
"IV HIT OV PARK VEH OCCURRENCE: \n\n"
"11/26/2013 12/6/2013 000001155289 1 MEDPIP US 301 S/B - MASSEY, MD MD C 0.00 0.00 0.00 0.00 0.00\n\n"
"HARDIMAN, LEE LEE HARDIMAN CLAIMANT REAR-ENDED INSURED OCCURRENCE: 000001155234\n\n"
"5/12/2014 5/13/2014 000001169287 3 PD AUBURN RD/RT 322 OH C 0.00 9,375.72 0.00 85.00 9,460.72\n\n"
"SHAKER, SUE JOHN KONKOL RECORD ONLY OCCURRENCE: \n\n"
"5/29/2014 10/9/2014 000001182641 3 PD PILOT TS/5820 HAGMAN RD - \n"
"TOLEDO, OH\n\n"
"OH C 0.00 11,509.17 0.00 277.25 11,786.42\n\n"
"PILOT TRAVEL \n"
"CENTERS LLC 5508 \n"
"LONAS RD\n\n"
"JEFF BORKOWSKI INSURED VEHICLE HIT OBJECT OCCURRENCE: \n\n"
"Page 3 of 7 Confidential - Property of National Interstate 6/8/2018\n\n\n\n"
"Loss Run Report KUHNLE BROTHERS, INC. Evaluation Date: 6/7/2018\n\n"
"Company: 01 NATIONAL INTERSTATE INS CO Account Number: 4000010531 Broker: NATIONAL RISK MANAGEMENT SERV.\n\n"
"Date of \n"
"Loss\n\n"
"Report \n"
"Date File Number ID Type\n\n"
" \n"
"Location of Loss\n\n"
" \n"
"ST\n\n"
" \n"
"Status\n\n"
"Claimant Driver Facts of Loss Loss Reserve Loss Paid Exp Reserve Exp Paid Total Incurred\n\n"
"6/20/2014 3/4/2015 000001195524 3 PD 15 ALLEN ST - MYSTIC, CT CT C 0.00 0.00 0.00 0.00 0.00\n\n"
"BULK CONNECTION \n"
"INC 15 ALLEN \n"
"STREET\n\n"
"U U PROPERTY DAMAGE OCCURRENCE: \n\n"
"8/7/2014 8/8/2014 000001176918 1 PD I-80 AT MM 146 REST STOP - \n"
"FREEMONT, IN\n\n"
"IN C 0.00 0.00 0.00 0.00 0.00\n\n"
"KUHNLE BROTHERS, \n"
"INC. 14905 CROSS \n"
"CREEK PARKWAY\n\n"
"JOHN KONKOL RECORD ONLY OCCURRENCE: \n\n"
"Subtotal 0.00 168,108.92 0.00 362.25 168,471.17\n\n"
"Auto Physical Damage\n\n"
"11/26/2013 12/6/2013 000001155234 1 COLL US 301 S/B - MASSEY, MD MD C 0.00 0.00 0.00 569.25 569.25\n\n"
"KUHNLE BROTHERS, \n"
"INC. 14905 CROSS \n"
"CREEK PARKWAY\n\n"
"LEE HARDIMAN CLAIMANT REAR-ENDED INSURED OCCURRENCE: 000001155234\n\n"
"Subtotal 0.00 0.00 0.00 569.25 569.25\n\n"
"End: Policy Number: CAT001053101 Policy Term: 9/1/2013 to 9/1/2014 0.00 168,108.92 0.00 931.50 169,040.42\n\n"
"Start: Policy Number: EXT001053101 Policy Term: 9/1/2013 to 9/1/2014\n\n"
"000000000000 0 NOTHING TO REPORT 0.00 0.00 0.00 0.00 0.00\n\n"
"OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: EXT001053101 Policy Term: 9/1/2013 to 9/1/2014 0.00 0.00 0.00 0.00 0.00\n\n"
"Start: Policy Number: GLT001053101 Policy Term: 9/1/2013 to 9/1/2014\n\n"
"000000000000 0 NOTHING TO REPORT 0.00 0.00 0.00 0.00 0.00\n\n"
"OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: GLT001053101 Policy Term: 9/1/2013 to 9/1/2014 0.00 0.00 0.00 0.00 0.00\n\n"
"Page 4 of 7 Confidential - Property of National Interstate 6/8/2018\n\n\n\n"
"Loss Run Report KUHNLE BROTHERS, INC. Evaluation Date: 6/7/2018\n\n"
"Company: 01 NATIONAL INTERSTATE INS CO Account Number: 4000010531 Broker: NATIONAL RISK MANAGEMENT SERV.\n\n"
"Date of \n"
"Loss\n\n"
"Report \n"
"Date File Number ID Type\n\n"
" \n"
"Location of Loss\n\n"
" \n"
"ST\n\n"
" \n"
"Status\n\n"
"Claimant Driver Facts of Loss Loss Reserve Loss Paid Exp Reserve Exp Paid Total Incurred\n\n"
"Start: Policy Number: CAT001053102 Policy Term: 9/1/2014 to 9/1/2015\n\n"
"Auto Liability\n\n"
"10/22/2014 11/10/2014 000001185441 3 PD CRANE AVENUE BRIDGE - \n"
"KENT, OH\n\n"
"OH C 0.00 0.00 0.00 65.00 65.00\n\n"
"CLEGG, BRIAN DEXTER BRITTNEY PER OVC: IV MADE TURN HIT OV OCCURRENCE: \n\n"
"1/6/2015 1/7/2015 000001190070 3 PD ROUTE 70 E/B - BEDFORD, PA PA C 0.00 6,121.84 0.00 0.00 6,121.84\n\n"
"SUDLER, JUDITH AL CASTERLINE INSURED REARENDED CLAIMANT OCCURRENCE: \n\n"
"1/8/2015 4/24/2015 000001200301 1 PD CT C 0.00 29,722.95 0.00 963.50 30,686.45\n\n"
"NY DEPT OF \n"
"ENVIRONMENTAL \n"
"625 BROADWAY\n\n"
"ED KRASOUSKI FERIC SPILLED OUT OCCURRENCE: \n\n"
"1/8/2015 4/24/2015 000001200301 2 PD CT C 0.00 16,004.67 0.00 963.50 16,968.17\n\n"
"CT DEPT. OF ENERGY \n"
"& 79 ELM STREET\n\n"
"ED KRASOUSKI FERIC SPILLED OUT OCCURRENCE: \n\n"
"1/20/2015 1/20/2015 000001191090 3 PD JOHNSTON & SEVILLE - \n"
"CLEVELAND, OH\n\n"
"OH C 0.00 973.62 0.00 0.00 973.62\n\n"
"GREATER CLEVELAND \n"
"RTA 1240 W 6TH \n"
"ST\n\n"
"JONATHON \n"
"STOCKDALE\n\n"
"IV AND OV COLLIDED OCCURRENCE: \n\n"
"1/20/2015 1/20/2015 000001191090 4 BI JOHNSTON & SEVILLE - \n"
"CLEVELAND, OH\n\n"
"OH C 0.00 250.00 0.00 0.00 250.00\n\n"
"SLEDGE, TYRA JONATHON \n"
"STOCKDALE\n\n"
"IV AND OV COLLIDED OCCURRENCE: \n\n"
"1/20/2015 1/26/2015 000001191565 3 PD STATE ROUTE 57 - ELYRIA, OH OH C 0.00 0.00 0.00 0.00 0.00\n\n"
"U-HAUL \n"
"INCORPORATED\n\n"
"JAMES \n"
"CASTERLINE\n\n"
"RECORD ONLY OCCURRENCE: \n\n"
"1/20/2015 1/26/2015 000001191565 4 BI STATE ROUTE 57 - ELYRIA, OH OH C 0.00 20,000.00 0.00 0.00 20,000.00\n\n"
"BEAVERS, JAYSON JAMES \n"
"CASTERLINE\n\n"
"RECORD ONLY OCCURRENCE: \n\n"
"1/20/2015 1/26/2015 000001191565 5 BI STATE ROUTE 57 - ELYRIA, OH OH C 0.00 8,500.00 0.00 0.00 8,500.00\n\n"
"WORLEY, DANIEL JAMES \n"
"CASTERLINE\n\n"
"RECORD ONLY OCCURRENCE: \n\n"
"Page 5 of 7 Confidential - Property of National Interstate 6/8/2018\n\n\n\n"
"Loss Run Report KUHNLE BROTHERS, INC. Evaluation Date: 6/7/2018\n\n"
"Company: 01 NATIONAL INTERSTATE INS CO Account Number: 4000010531 Broker: NATIONAL RISK MANAGEMENT SERV.\n\n"
"Date of \n"
"Loss\n\n"
"Report \n"
"Date File Number ID Type\n\n"
" \n"
"Location of Loss\n\n"
" \n"
"ST\n\n"
" \n"
"Status\n\n"
"Claimant Driver Facts of Loss Loss Reserve Loss Paid Exp Reserve Exp Paid Total Incurred\n\n"
"3/3/2015 3/9/2015 000001195919 3 PD W. 14TH ST & STEELYARD - \n"
"CLEVELAND, OH\n\n"
"OH C 0.00 6,520.66 0.00 0.00 6,520.66\n\n"
"MONROE, BRENDA JOHN MANFREDI RECORD ONLY OCCURRENCE: \n\n"
"3/3/2015 3/9/2015 000001195919 4 BI W. 14TH ST & STEELYARD - \n"
"CLEVELAND, OH\n\n"
"OH C 0.00 7,500.00 0.00 0.50 7,500.50\n\n"
"MONROE, BRENDA K JOHN MANFREDI RECORD ONLY OCCURRENCE: \n\n"
"4/12/2015 4/13/2015 000001199069 4 PD I-35 - HILLSBORO, TX TX C 0.00 0.00 0.00 0.00 0.00\n\n"
"U, U U GLENN LONG RECORD ONLY OCCURRENCE: \n\n"
"5/20/2015 5/20/2015 000001202722 3 PD RT 42 - HIGHLAND PARK, IL IL C 0.00 1,462.53 0.00 0.00 1,462.53\n\n"
"RENTAL CAR, \n"
"ENTERPRISE\n\n"
"DANNY SAMMONS RECORD ONLY OCCURRENCE: \n\n"
"6/2/2015 6/3/2015 000001203989 3 PD FERRY & LEXINGTON - \n"
"NEWARK, NJ\n\n"
"NJ C 0.00 1,989.02 0.00 132.93 2,121.95\n\n"
"RIVERA, LUIS CHRIS LICKLY OV & IV COLLIDED OCCURRENCE: \n\n"
"6/9/2015 6/10/2015 000001204641 2 PD RT 495 - OYSTER BAY, NY NY C 0.00 0.00 0.00 0.00 0.00\n\n"
"HIRSHON, STEVEN ED KRASOUSKY RECORD ONLY OCCURRENCE: \n\n"
"Subtotal 0.00 99,045.29 0.00 2,125.43 101,170.72\n\n"
"Auto Physical Damage\n\n"
"7/23/2015 11/9/2015 000001217916 1 OTHER OH C 0.00 0.00 0.00 700.00 700.00\n\n"
"KUHNLE BROTHERS, \n"
"INC. 14905 CROSS \n"
"CREEK PKWY\n\n"
"IVS DAMAGED OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 700.00 700.00\n\n"
"End: Policy Number: CAT001053102 Policy Term: 9/1/2014 to 9/1/2015 0.00 99,045.29 0.00 2,825.43 101,870.72\n\n"
"Start: Policy Number: EXT001053102 Policy Term: 9/1/2014 to 9/1/2015\n\n"
"000000000000 0 NOTHING TO REPORT 0.00 0.00 0.00 0.00 0.00\n\n"
"OCCURRENCE: \n\n"
"Page 6 of 7 Confidential - Property of National Interstate 6/8/2018\n\n\n\n"
"Loss Run Report KUHNLE BROTHERS, INC. Evaluation Date: 6/7/2018\n\n"
"Company: 01 NATIONAL INTERSTATE INS CO Account Number: 4000010531 Broker: NATIONAL RISK MANAGEMENT SERV.\n\n"
"Date of \n"
"Loss\n\n"
"Report \n"
"Date File Number ID Type\n\n"
" \n"
"Location of Loss\n\n"
" \n"
"ST\n\n"
" \n"
"Status\n\n"
"Claimant Driver Facts of Loss Loss Reserve Loss Paid Exp Reserve Exp Paid Total Incurred\n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: EXT001053102 Policy Term: 9/1/2014 to 9/1/2015 0.00 0.00 0.00 0.00 0.00\n\n"
"Start: Policy Number: GLT001053102 Policy Term: 9/1/2014 to 9/1/2015\n\n"
"General Liability\n\n"
"2/2/2015 6/11/2015 000001204812 1 PD UPS FACILITY - \n"
"LONDONDERRY, NH\n\n"
"NH C 0.00 17,725.76 0.00 0.00 17,725.76\n\n"
"CRYOTECH \n"
" 6103 ORTHOWAY\n\n"
"CRAIG FLINCHUN PRODUCT NOT DELIVERED OCCURRENCE: \n\n"
"Subtotal 0.00 17,725.76 0.00 0.00 17,725.76\n\n"
"End: Policy Number: GLT001053102 Policy Term: 9/1/2014 to 9/1/2015 0.00 17,725.76 0.00 0.00 17,725.76\n\n"
"Start: Policy Number: EXT001053103 Policy Term: 9/1/2015 to 9/1/2016\n\n"
"000000000000 0 NOTHING TO REPORT 0.00 0.00 0.00 0.00 0.00\n\n"
"OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: EXT001053103 Policy Term: 9/1/2015 to 9/1/2016 0.00 0.00 0.00 0.00 0.00\n\n"
"Start: Policy Number: EXT001053104 Policy Term: 9/1/2016 to 9/1/2017\n\n"
"000000000000 0 NOTHING TO REPORT 0.00 0.00 0.00 0.00 0.00\n\n"
"OCCURRENCE: \n\n"
"Subtotal 0.00 0.00 0.00 0.00 0.00\n\n"
"End: Policy Number: EXT001053104 Policy Term: 9/1/2016 to 9/1/2017 0.00 0.00 0.00 0.00 0.00\n\n"
"4000010531 0.00 307,765.13 0.00 19,818.36 327,583.49\n\n"
"Page 7 of 7 Confidential - Property of National Interstate 6/8/2018")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.