$re = '/^\S.{0,18}\S\b|\b\S.{0,18}\S$/m';
$str = 'Hello, World! This is a reallly long string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);