$re = '/(.| )*(?= \d+:\d+)/';
$str = '1 Post 12:34
4 Posts 15:11
Deleted 8:4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);