# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(В|в) соответствии([^\n]\n?)*Российской\s+Федерации([^\n)]\n?)*\)"
test_str = (" ПРИКАЗ\n\n"
" МИНИСТЕРСТВА ПРИРОДНЫХ РЕСУРСОВ И ЭКОЛОГИИ\n"
" РОССИЙСКОЙ ФЕДЕРАЦИИ\n\n"
" от 29 февраля 2016 г. N 54\n\n"
" Об утверждении требований к содержанию геологической\n"
" информации о недрах и формы ее представления\n\n"
" Зарегистрирован Минюстом России 25 марта 2016 г.\n"
" Регистрационный N 41560\n\n"
" В соответствии с пунктом 5.2.29. Положения о Министерстве\n"
" природных ресурсов и экологии Российской Федерации, утвержденного\n"
" постановлением Правительства Российской Федерации от 11 ноября\n"
" 2015 г. N 1219 (Собрание законодательства Российской Федерации,\n"
" 2015, N 47, ст. 6586; 2016, N 2, ст. 325) приказываю:\n"
" Утвердить прилагаемые требования к содержанию геологической\n"
" информации о недрах и форму ее представления.\n\n"
" 1. Настоящие Требования разработаны в соответствии с\n"
" подпунктом 5.2.29. Положения о Министерстве природных ресурсов и\n"
" экологии Российской Федерации, утвержденного постановлением\n"
" Правительства Российской Федерации от 11 ноября 2015 г. N 1219\n"
" (Собрание законодательства Российской Федерации, 2015, N 47,\n"
" ст. 6586; 2016, N 2, ст. 325) и устанавливают требования к\n"
" содержанию геологической информации о недрах и форму ее\n"
" представления.\n"
" ...........\n\n"
" 10. Материалы по ..... запасов полезных ископаемых,\n"
" геологической, экономической и экологической информации о\n"
" предоставляемых в пользование участках недр, в соответствии с\n"
" постановлением Правительства Российской Федерации от 11 февраля\n"
" 2005 г. N 69 \"О государственной экспертизе запасов полезных\n"
" ископаемых, геологической, экономической и экологической информации\n"
" о предоставляемых в пользование участках недр, размере и порядке\n"
" взимания платы за ее проведение\" (Собрание законодательства\n"
" Российской Федерации, 2005, N 8, ст. 651; 2006, N 32, ст. 3570;\n"
" 2007, N 5, ст. 663; 2009, N 18, ст. 2248; 2014, N 6, ст. 594; 2015,\n"
" N 50, ст. 7171; официальный интернет-портал правовой информации\n"
" http://www.pravo.gov.ru, 20 февраля 2016 г., N 0001201602200017).\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.