$re = '/\s(?=\w+:)/m';
$str = 'id:123 name:test pumpe desc:pumpe p123';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);