#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^1[3-4|6].*"
Local $sString = "13" & @CRLF & _
"13.1" & @CRLF & _
"13.1.1" & @CRLF & _
"13.1.2" & @CRLF & _
"13.1.2" & @CRLF & _
"13.1.3" & @CRLF & _
"13.2" & @CRLF & _
"13.2.1" & @CRLF & _
"13.2.2" & @CRLF & _
"13.2.3" & @CRLF & _
"13.3" & @CRLF & _
"13.3.1" & @CRLF & _
"13.4" & @CRLF & _
"13.4" & @CRLF & _
"13.4.1" & @CRLF & _
"13.4.1" & @CRLF & _
"13.5" & @CRLF & _
"13.5.1" & @CRLF & _
"13.6" & @CRLF & _
"13.6.1" & @CRLF & _
"13.7" & @CRLF & _
"14" & @CRLF & _
"14.0.1" & @CRLF & _
"14.1" & @CRLF & _
"14.2" & @CRLF & _
"14.2" & @CRLF & _
"14.2.1" & @CRLF & _
"14.3" & @CRLF & _
"14.4" & @CRLF & _
"14.4.1" & @CRLF & _
"14.4.2" & @CRLF & _
"14.5" & @CRLF & _
"14.5.1" & @CRLF & _
"14.6 Beta 3" & @CRLF & _
"14.6 RC" & @CRLF & _
"14.6 RC 2" & @CRLF & _
"14.6" & @CRLF & _
"14.7 Beta 1" & @CRLF & _
"14.7 Beta 2" & @CRLF & _
"14.7 Beta 3" & @CRLF & _
"14.7 Beta 4" & @CRLF & _
"14.7 Beta 5" & @CRLF & _
"14.7 RC" & @CRLF & _
"14.7" & @CRLF & _
"14.7.1" & @CRLF & _
"14.8" & @CRLF & _
"14.8.1" & @CRLF & _
"15.0 Beta 1" & @CRLF & _
"15.0 Beta 2" & @CRLF & _
"15.0 Beta 2" & @CRLF & _
"15.0 Beta 3" & @CRLF & _
"15.0 Beta 4" & @CRLF & _
"15.0 Beta 5" & @CRLF & _
"15.0 Beta 6" & @CRLF & _
"15.0 Beta 7" & @CRLF & _
"15.0 Beta 8" & @CRLF & _
"15.0 RC" & @CRLF & _
"15" & @CRLF & _
"15.1 Beta 1" & @CRLF & _
"15.1 Beta 2" & @CRLF & _
"15.0.1" & @CRLF & _
"15.1 Beta 3" & @CRLF & _
"15.0.2" & @CRLF & _
"15.1 Beta 4" & @CRLF & _
"15.1 RC 1" & @CRLF & _
"15.1 RC 2" & @CRLF & _
"15.1" & @CRLF & _
"15.2 Beta 1" & @CRLF & _
"15.2 Beta 2" & @CRLF & _
"15.2 Beta 3" & @CRLF & _
"15.1.1" & @CRLF & _
"15.2 Beta 4" & @CRLF & _
"15.2 RC" & @CRLF & _
"15.2 RC 2" & @CRLF & _
"15.2" & @CRLF & _
"15.3 Beta 1" & @CRLF & _
"15.2.1" & @CRLF & _
"15.3 Beta 2" & @CRLF & _
"15.3 RC" & @CRLF & _
"15.3" & @CRLF & _
"15.4 Beta 1" & @CRLF & _
"15.4 Beta 2" & @CRLF & _
"15.3.1" & @CRLF & _
"15.4 Beta 3" & @CRLF & _
"15.4 Beta 4" & @CRLF & _
"15.4 Beta 5" & @CRLF & _
"15.4 RC" & @CRLF & _
"15.4" & @CRLF & _
"15.4.1" & @CRLF & _
"15.5 Beta 1" & @CRLF & _
"15.5 Beta 2" & @CRLF & _
"15.5 Beta 3" & @CRLF & _
"15.5 Beta 4" & @CRLF & _
"15.5 RC" & @CRLF & _
"15.5" & @CRLF & _
"15.6 Beta 1" & @CRLF & _
"15.6 Beta 2" & @CRLF & _
"15.6 Beta 3" & @CRLF & _
"15.6 Beta 4" & @CRLF & _
"15.6 Beta 5" & @CRLF & _
"15.6 RC" & @CRLF & _
"15.6 RC 2" & @CRLF & _
"15.6" & @CRLF & _
"15.6.1" & @CRLF & _
"15.7 RC" & @CRLF & _
"15.7" & @CRLF & _
"15.7.1 RC" & @CRLF & _
"15.7.1" & @CRLF & _
"15.7.2 RC" & @CRLF & _
"16.0 Beta 1" & @CRLF & _
"16.0 Beta 2" & @CRLF & _
"16.0 Beta 3" & @CRLF & _
"16.0 Beta 3" & @CRLF & _
"16.0 Public Beta 1" & @CRLF & _
"16.0 Beta 4" & @CRLF & _
"16.0 Public Beta 2" & @CRLF & _
"16.0 Beta 5" & @CRLF & _
"16.0 Public Beta 3" & @CRLF & _
"16.0 Beta 6" & @CRLF & _
"16.0 Public Beta 4" & @CRLF & _
"16.0 Beta 7" & @CRLF & _
"16.0 Public Beta 5" & @CRLF & _
"16.0 Beta 8" & @CRLF & _
"16.0 Public Beta 6" & @CRLF & _
"16.0 RC" & @CRLF & _
"16" & @CRLF & _
"16.1 Beta 1" & @CRLF & _
"16.0.1" & @CRLF & _
"16.1 Public Beta 1" & @CRLF & _
"16.1 Beta 2" & @CRLF & _
"16.1 Public Beta 2" & @CRLF & _
"16.0.2" & @CRLF & _
"16.1 Beta 3" & @CRLF & _
"16.1 Public Beta 3" & @CRLF & _
"16.1 Beta 4" & @CRLF & _
"16.1 Public Beta 4" & @CRLF & _
"16.0.3" & @CRLF & _
"16.1 Beta 5" & @CRLF & _
"16.1 Public Beta 5" & @CRLF & _
"16.1 RC" & @CRLF & _
"16.1" & @CRLF & _
"16.2 Beta 1" & @CRLF & _
"16.2 Public Beta 1" & @CRLF & _
"16.2 Beta 2" & @CRLF & _
"16.1.1" & @CRLF & _
"16.2 Public Beta 2" & @CRLF & _
"16.2 Beta 3" & @CRLF & _
"16.2 Public Beta 3" & @CRLF & _
"16.2 (a)" & @CRLF & _
"16.2 (b)" & @CRLF & _
"16.1.2" & @CRLF & _
"16.2 Beta 4" & @CRLF & _
"16.2 RC"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")