$re = '/[^\s\/]*\/IN\b([^\/]*\/(?!IN\b|:\b|NN\b)[^\s^\/]*\b)*/';
$str = 'Alun-alun/NNP Jombang/NNP tepatnya/RB Depan/IN SMP/NNP 2/CDP Jombang/NNP Besok/NNP pagi/NN :/: :/: :/: Minggu/NNP';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);